27 de abr de 2009

Estruturas de decisão - Lógica de Programação, Algoritmos - Aula 13

Aula 13 - 9/9/2003
Estrutura de seleção (ou decisão)


Uma estrutura de seleção permite a escolha de uma ação ou grupo de ações (bloco) a ser executado quando determinadas condições, representadas por expressões lógicas ou relacionais, são ou não satisfeitas.


Seleção simples


...
se
   entao
  
fimse;
...
Exemplo


...
se NOTA > 5
  então
    escreva('Aprovado');
fimse;
...




[ou, no caso de mais um comando, usar sempre os marcadores de bloco:]

...
se
  então
    início
    ;
    ;
    ...
    ;
    fim;
fimse;


Exemplo:

...
se NOTA>=5
  então
    início
      escreva('Aprovado');
      escreva('Não esquecer de fazer a matrícula');
    fim;
fimse;
...


Seleção Composta

se
   então
      ;
      senao
      ;
fimse


se
  então
    início
    ;
  …
    ;
  fim;
  senão
  inicio
    ;
  …
    ;
   fim;
fimse;


exemplo

se NOTA > =5
  então
    escreva('Aprovado');
  senao
    escreva('Reprovado');
fimse;

Nenhum comentário: